Eclipse 3.5无法安装插件
收藏

我真的不知道Eclipse 3.5发生了什么(3.5.0或3.5.1,相同的问题),但是直到2天我才与Eclipse奋斗,寻找一种方法来使插件安装通过“安装新软件屏幕” !!!我访问了许多论坛和博客,尝试了许多解决方案,但徒劳无功:每次当前的问题消失并出现一个新的问题。

我正在尝试使其在我的办公室中正常工作,因此在代理后面。到目前为止,我得到的最好的建议是有关NTLM代理的已知问题的建议:http://wiki.eclipse.org/ECF_Filetransfer_Support_for_NTLMv2_Proxies。我放置了提示,但是现在我收到一条新的错误消息:Eclipse根本找不到存储库...例如,这是我现在通过Galileo更新站点本身获得的信息:

org.eclipse.equinox.internal.provisional.p2.core.ProvisionException: No repository found at http://download.eclipse.org/releases/galileo.
    at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.fail(AbstractRepositoryManager.java:380)
    at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:606)
    at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
    at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:88)
    at org.eclipse.equinox.internal.provisional.p2.ui.operations.ProvisioningUtil.loadMetadataRepository(ProvisioningUtil.java:88)
    at org.eclipse.equinox.internal.provisional.p2.ui.QueryableMetadataRepositoryManager.doLoadRepository(QueryableMetadataRepositoryManager.java:55)
    at org.eclipse.equinox.internal.provisional.p2.ui.QueryableRepositoryManager.loadRepository(QueryableRepositoryManager.java:195)
    at org.eclipse.equinox.internal.provisional.p2.ui.QueryableRepositoryManager.loadAll(QueryableRepositoryManager.java:108)
    at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$2.run(PreloadingRepositoryHandler.java:71)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

与http://download.eclipse.org/eclipse/updates/3.5或http://download.eclipse.org/tools/mylyn/update/e3.4/以及其他网站相同:没有人可以使用。

请有人帮忙!

PS:下面有更多详细信息:

我也与第三方软件有同样的问题...例如:http://www.epic-ide.org/updates/testing/site.xml ....相同的错误消息。

如果转到“首选项”>“安装/更新”>“可用软件站点”,请单击任何站点,然后在“测试连接”上单击该错误消息,我将获得ProvisionException(当我单击详细信息时):

无法阅读位于http://download.eclipse.org/technology/epp/packages/galileo/site.xml的存储库。   无法阅读位于http://download.eclipse.org/technology/epp/packages/galileo/site.xml的存储库。   服务器重定向太多次(20)

the solution is: add following lines to your eclipse.ini file (before -vmargs): (verified on 3.5 ; 3.5.1; 3.6.2)

-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient
-Dhttp.proxyPort=8080
-Dhttp.proxyHost=myproxy
-Dhttp.proxyUser=mydomain\myusername
-Dhttp.proxyPassword=mypassword
-Dhttp.nonProxyHosts=localhost|127.0.0.1

最佳答案

我们这里有很多问题,即在代理支持方面。 我们最终使用Pulse:http://www.poweredbypulse.com/

Pulse内置了对一些插件的支持,但是,您可以轻松添加第三方插件,甚至本地jar文件。

奇怪的是,它并不总是使用内置的Eclipse功能,因此有时当Eclipse变得困难时(例如在我们的代理业务中),您可以使用Pulse解决它。

    公众号
    关注公众号订阅更多技术干货!