20.04无法从php7.4降级到PHP 7.3

我需要更改版本才能在laravel项目上工作。

我试过了:

sudo apt install software-properties-common

sudo add-apt-repository ppa:ondrej/php

sudo apt update

sudo apt-get install php7.3 libapache2-mod-php7.3 php7.3-cli php7.3-mysql php7.3-gd php7.3-imagick php7.3-recode php7.3-tidy php7.3-xmlrpc

之后,我得到了:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'php7.3-json' for regex 'php7.3'
Note, selecting 'php7.3-dev' for regex 'php7.3'
Note, selecting 'libapache2-mod-php7.3' for regex 'php7.3'
Package libapache2-mod-php7.3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-php7.3' has no installation candidate
E: Unable to locate package php7.3-cli
E: Couldn't find any package by glob 'php7.3-cli'
E: Couldn't find any package by regex 'php7.3-cli'
E: Unable to locate package php7.3-mysql
E: Couldn't find any package by glob 'php7.3-mysql'
E: Couldn't find any package by regex 'php7.3-mysql'
E: Unable to locate package php7.3-gd
E: Couldn't find any package by glob 'php7.3-gd'
E: Couldn't find any package by regex 'php7.3-gd'
E: Unable to locate package php7.3-imagick
E: Couldn't find any package by glob 'php7.3-imagick'
E: Couldn't find any package by regex 'php7.3-imagick'
E: Unable to locate package php7.3-recode
E: Couldn't find any package by glob 'php7.3-recode'
E: Couldn't find any package by regex 'php7.3-recode'
E: Unable to locate package php7.3-tidy
E: Couldn't find any package by glob 'php7.3-tidy'
E: Couldn't find any package by regex 'php7.3-tidy'
E: Unable to locate package php7.3-xmlrpc
E: Couldn't find any package by glob 'php7.3-xmlrpc'
E: Couldn't find any package by regex 'php7.3-xmlrpc'
评论