20.04 Focal Fossa-pgAdmin4依赖于libpython,但已安装

Ubuntu 20.04焦点

尝试为PostgreSQL安装pgAdmin4。

sudo apt-get install -f pgadmin4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pgadmin4 : Depends: libpython3.7 (>= 3.7.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

我已经安装了libpython3.8,那么为什么不易于识别呢?

sudo apt-get install libpython3.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpython3.8 is already the newest version (3.8.2-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
评论