无法从18.04下载存储库信息

我正在运行18.04LTS,并试图让我的系统下载20.04版本。不带参数运行update-manager失败。它开始下载资源库信息,完成90%的工作,然后显示“无法下载资源库信息。检查您的Internet连接”中止。

我能够ping,traceroute和http到www.ubuntu.com和archive.ubuntu.com没有问题。我的互联网连接正好适合其他目的地。

现在,“ apt更新”不起作用。

sudo apt update [sudo] password for jms: Hit:1 http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Ign:4 http://ppa.launchpad.net/videolan/stable-daily/ubuntu bionic InRelease
Err:5 http://ppa.launchpad.net/videolan/stable-daily/ubuntu bionic Release
404 Not Found [IP: 2001:67c:1560:8008::15 80] Get:6 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB] Get:7 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB] Exception ignored in: <_io.TextIOWrapper name='' mode='w' encoding='UTF-8'> BrokenPipeError: [Errno 32] Broken pipe Reading package lists... Done E: The repository 'http://ppa.launchpad.net/videolan/stable-daily/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: Skipping acquire of configured file 'allow-insecure=yes/binary-i386/Packages' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/binary-amd64/Packages' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/i18n/Translation-en' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/i18n/Translation-en_US' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/dep11/Components-amd64.yml' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/dep11/icons-48x48.tar' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/dep11/icons-64x64.tar' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?) W: Skipping acquire of configured file 'allow-insecure=yes/cnf/Commands-amd64' as repository 'http://ppa.launchpad.net/mc3man/bionic-media/ubuntu bionic InRelease' doesn't have the component 'allow-insecure=yes' (component misspelt in sources.list?)

评论