如何在Linux Mint 18 / Ubuntu 16.04中的VLC中启用VA-API

我有基于Ubuntu 16.04的Linux Mint 18.3。我无法在VLC中启用VA-API(我可以选择的端口中不存在VA-API输出,只有VDPAU,OpenGL GLX,X11,XCB,帧缓冲区等)。

我有一个使用集成GPU的Intel i5-4200M CPU。

在相同的硬件上,使用来自Ubuntu repo(包括VLC)的软件包,基于Ubuntu 14.04的Linux Mint 17.x都可以正常工作。

我进行了很多搜索,但找不到错误所在。

已安装以下软件包:

vlc 2.2.2-5ubuntu0.16.04.4
libva1 1.8.1-1~xenial
libva-x11-1 1.8.1-1~xenial
libva-wayland1 1.8.1-1~xenial (although I don't use Wayland)
libva-drm1 1.8.1-1~xenial
i965-va-driver 1.8.1-1~xenial

vainfo报告:

libva info: VA-API version 0.40.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_40
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.40 (libva )
vainfo: Driver version: Intel i965 driver for Intel(R) Haswell Mobile - 1.8.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD

On other pages I read libva-intel-vaapi-driver should be installed, but no candidate exists: I also read it's just a source package upon which i965-va-driver is built, so I should be fine with it.

vainfo输出似乎表明一切正常,事实上,使用该配置,正如我已经说过的那样,我可以使用Mint 17 / Ubuntu 14.04在VLC输出首选项中选择VA-API,但不能使用Mint 18 / Ubuntu 16.04。

评论