无法执行apt更新

嗨,我运行“ apt update”时收到此错误

I guess http://ph.archive.ubuntu.com/ubuntu is down. But how can I connect to a different server to update my system?

评论