为极老的设备构建网站以转换Jquery或Jquery 1.12的最佳方法?

jquery only supports the last 2 versions of Chrome, Firefox, Safari and Edge, and the latest version of Opera, and, oddly, IE all the way back to 9. For earlier browsers jquery recommends you use version 1.12.

我需要在非常旧的智能手机上支持非常早期的浏览器。我并不局限于jquery,但它似乎是早期浏览器差异的有用隔离层,并且比纯Javascript稍快一些。我使用它,而不是使用任何更现代的方法来保存电池和性能。我还使用了Bootstrap 4,popper和axios的子集,并带有用于Promise和IE5上的html5的polyfills。

用babeljs转换jquery以实现古老的浏览器兼容性是否是明智的策略?还是Jquery 1.12走了?我在浏览器中没有做太多事情-只是一些本地状态,DOM操作和XHR请求。建立极旧设备的站点的常见或最佳方法是什么?

评论