无法安装ffmpeg-智能解决方案不起作用

我正在使用Ubuntu 16.04。我无法安装ffmpeg。

1)智能不起作用。

2)已启用受限和Universe存储库。

3) dpkg --get-selections | grep hold outputs nothing.

4) apt-mark showhold outputs nothing

(base) h@cheemc52:~/opencv/build$ sudo apt-get install ffmpeg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ffmpeg : Depends: libavcodec56 (>= 10:2.6.9) but it is not going to be installed
          Depends: libavdevice56 (>= 10:2.6.9) but it is not going to be installed
          Depends: libavfilter5 (>= 10:2.6.9) but it is not going to be installed
          Depends: libavformat56 (>= 10:2.6.9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

我尝试使用aptitude,但是它提供的解决方案根本无法使用。 解决方案1。

(base) h@cheemc52:~$ sudo aptitude install ffmpeg
The following NEW packages will be installed:
  ffmpeg libaacplus2{a} libass5{a} libavcodec56{ab} libavdevice56{a} libavfilter5{a} libavformat56{ab} libavresample2{a} libfaac0{a} libfdk-aac1{a} libpostproc53{a}
  libswresample1{a} libutvideo15{a} libvidstab1.0{a} libvo-aacenc0{a} libvo-amrwbenc0{a} libx264-146{a} libx265-51{a}
0 packages upgraded, 18 newly installed, 0 to remove and 5 not upgraded.
Need to get 8,460 kB/8,543 kB of archives. After unpacking 23.1 MB will be used.
The following packages have unmet dependencies:
 libavformat56 : Depends: libgnutls-deb0-28 (>= 3.3.0) which is a virtual package and is not provided by any available package.

 libavcodec56 : Depends: libvpx1 (>= 1.3.0) which is a virtual package and is not provided by any available package.

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     ffmpeg [Not Installed]
2)     libavcodec56 [Not Installed]
3)     libavdevice56 [Not Installed]
4)     libavfilter5 [Not Installed]
5)     libavformat56 [Not Installed]



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

(base) h@cheemc52:~$ ffmpeg
-bash: /usr/bin/ffmpeg: No such file or directory

解决方案2。所有其他解决方案看起来与2类似。

The following actions will resolve these dependencies:

      Install the following packages:
1)      ffmpeg [7:2.8.15-0ubuntu0.16.04.1 (now, xenial-security, xenial-updates)]
2)      libavdevice-ffmpeg56 [7:2.8.15-0ubuntu0.16.04.1 (xenial-security, xenial-updates)]
3)      libavfilter-ffmpeg5 [7:2.8.15-0ubuntu0.16.04.1 (xenial-security, xenial-updates)]
4)      libbs2b0 [3.1.0+dfsg-2.2 (xenial)]
5)      libflite1 [2.0.0-release-1 (xenial)]
6)      libopenal-data [1:1.16.0-3 (now, xenial)]
7)      libopenal1 [1:1.16.0-3 (now, xenial)]
8)      libpostproc-ffmpeg53 [7:2.8.15-0ubuntu0.16.04.1 (xenial-security, xenial-updates)]

      Keep the following packages at their current version:
9)      libavcodec56 [Not Installed]
10)     libavdevice56 [Not Installed]
11)     libavfilter5 [Not Installed]
12)     libavformat56 [Not Installed]



Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  ffmpeg libass5{a} libavdevice-ffmpeg56{a} libavfilter-ffmpeg5{a} libbs2b0{a} libflite1{a} libopenal-data{a} libopenal1{a} libpostproc-ffmpeg53{a}
0 packages upgraded, 9 newly installed, 0 to remove and 5 not upgraded.
Need to get 0 B/15.1 MB of archives. After unpacking 33.0 MB will be used.
Do you want to continue? [Y/n/?] y
dpkg: warning: files list file for package 'libopencv-ml2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-calib3d2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-legacy2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-contrib2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-core2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-features2d2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'python-opencv' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-photo2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-objdetect2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-flann2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-video2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-imgproc2.4v5:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libopencv-highgui2.4v5:amd64' missing; assuming package has no files currently installed
(Reading database ... 345098 files and directories currently installed.)
Preparing to unpack .../libopenal-data_1%3a1.16.0-3_all.deb ...
Unpacking libopenal-data (1:1.16.0-3) ...
Preparing to unpack .../libopenal1_1%3a1.16.0-3_amd64.deb ...
Unpacking libopenal1:amd64 (1:1.16.0-3) ...
Selecting previously unselected package libass5:amd64.
Preparing to unpack .../libass5_0.13.1-1_amd64.deb ...
Unpacking libass5:amd64 (0.13.1-1) ...
Selecting previously unselected package libbs2b0:amd64.
Preparing to unpack .../libbs2b0_3.1.0+dfsg-2.2_amd64.deb ...
Unpacking libbs2b0:amd64 (3.1.0+dfsg-2.2) ...
Selecting previously unselected package libflite1:amd64.
Preparing to unpack .../libflite1_2.0.0-release-1_amd64.deb ...
Unpacking libflite1:amd64 (2.0.0-release-1) ...
Selecting previously unselected package libpostproc-ffmpeg53:amd64.
Preparing to unpack .../libpostproc-ffmpeg53_7%3a2.8.15-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libpostproc-ffmpeg53:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Selecting previously unselected package libavfilter-ffmpeg5:amd64.
Preparing to unpack .../libavfilter-ffmpeg5_7%3a2.8.15-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libavfilter-ffmpeg5:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Selecting previously unselected package libavdevice-ffmpeg56:amd64.
Preparing to unpack .../libavdevice-ffmpeg56_7%3a2.8.15-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libavdevice-ffmpeg56:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Preparing to unpack .../ffmpeg_7%3a2.8.15-0ubuntu0.16.04.1_amd64.deb ...
Unpacking ffmpeg (7:2.8.15-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libopenal-data (1:1.16.0-3) ...
Setting up libopenal1:amd64 (1:1.16.0-3) ...
Setting up libass5:amd64 (0.13.1-1) ...
Setting up libbs2b0:amd64 (3.1.0+dfsg-2.2) ...
Setting up libflite1:amd64 (2.0.0-release-1) ...
Setting up libpostproc-ffmpeg53:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Setting up libavfilter-ffmpeg5:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Setting up libavdevice-ffmpeg56:amd64 (7:2.8.15-0ubuntu0.16.04.1) ...
Setting up ffmpeg (7:2.8.15-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...

(base) haziq@cheemc52:~$ ffmpeg
ffmpeg: error while loading shared libraries: libopencv_core.so.2.4: cannot open shared object file: No such file or directory
评论