Ubuntu错误请帮助

我跑了

sudo apt-get update 

and everything is fine, i proceed to run sudo apt-get -f install

我得到这个错误:

(Reading database ... 166567 files and directories currently installed.)
Preparing to unpack .../libjavascriptcoregtk-4.0-18_2.28.2-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libjavascriptcoregtk-4.0-18:amd64 (2.28.2-0ubuntu0.18.04.1) over (2.28.1-0ubuntu0.18.04.1) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: <decompress> subprocess returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/libjavascriptcoregtk-4.0-18_2.28.2-0ubuntu0.18.04.1_amd64.deb (--unpack):
 cannot copy extracted data for './usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18.16.5' to '/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18.16.5.dpkg-new': unexpected end of file or stream
Errors were encountered while processing:
 /var/cache/apt/archives/libjavascriptcoregtk-4.0-18_2.28.2-0ubuntu0.18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

有人可以请教吗?我很新,并且只想从计算机中删除引起此问题的所有内容。先感谢您。