无法从Python2升级到Python3(Ubuntu 19.04)

我在ubuntu(19.04)中安装了python2,我想将其升级到3.7。我安装了3.7,但仍显示为2.7。但是我可以运行python3并转到控制台,并且/ usr / bin中提供了python3.7可执行文件。尝试了互联网上所有可用的技巧,没有任何运气。然后我决定从/ usr / bin中删除python2.7可执行文件,现在我什至无法运行pip,因为它试图找到删除的2.7。得到以下消息。

bash:/ usr / bin / pip:/ usr / bin / python:错误的解释器:没有这样的文件或目录

我不知道为什么在机器上安装3.7并可用时,它仍试图像以前的女朋友一样找到2.7。