无法在Focal上安装libqt4-dev-尽管出现在启动板中,但“软件包不可用”

I'm trying to get Geant4 up and running, and one of the required dependencies is to have libqt4-dev. Despite the fact that it appears in launchpad (link), I keep on getting the following error:

  • 软件包libqt4-dev不可用,但是由另一个软件包引用。
  • 这可能意味着包裹丢失,已被废弃或
  • 仅可从其他来源获得
  • E:软件包“ libqt4-dev”没有候选安装

我已经尝试了sudo apt-get update和sudo apt-get upgrade以及跟随2017年的一些类似线程,但是还没有任何效果。我能够安装其他库,例如libx11-dev或libxerces-c-dev,因此我不认为这是存储库问题。有任何想法吗?

评论