找不到python-pip包

因此,今天我想安装python 2.7 GUI设计器后遇到了这个问题。 (皮古布)

我需要Tkinter软件包,因此我尝试运行

pip安装tkinter。

它没有工作,因为它没有被检测为命令。之后,我认为我必须安装python2 pip版本(我只有带pip的python 3和没有pip的python2)

我尝试运行此命令:

sudo apt-get update && sudo apt-get install python-pip

它说找不到python-pip软件包,我进入论坛查看是否有人遇到问题。

如我所料,其他人遇到了问题,解决方案是添加一些存储库。

问题是,当我添加存储库时,输出说我已经启用了它们。

我尝试再次运行该命令,但仍然无法找到它。

我将不胜感激。

评论