ubuntu 20.04上的python 3.7

我正在为ubuntu 20.04准备一个docker镜像,由于tensorflow 2.0的要求,我需要python 3.7。 Tensorflow在python 3.5到3.7上运行。运行apt install python3默认会安装python 3.8,这会中断我的tensorflow安装。

有什么办法可以为ubuntu 20.04的python 3.7获取apt软件包吗?由于它将被放置在docker映像中,因此我不想开始下载python 3.7源代码并进行编译。将这些命令放入Dockerfile对我来说是不堪重负的。有没有更简单的方法来为ubuntu 20.04获取Python 3.7?

跑步

sudo apt-cache madison python3

退货

python3 | 3.8.2-0ubuntu2 | http://in.archive.ubuntu.com/ubuntu focal/main amd64 Packages

评论
HeroA
HeroA

Tensorflow 2.2现在支持python 3.8,因此问题现在已经解决。

点赞
评论
心乱
心乱

Do you need Ubuntu 20.04? Ubuntu 18.04 comes with Python 3.6, and 3.7 available.

If you do, the deadsnakes PPA has Python 3.5-3.7 for Ubuntu 20.04 (Focal). To add it and install:

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt-get update
sudo apt-get install python3.7

P.s.我不是开发人员,也没有Tensorflow的经验,所以请带一点盐。

点赞
评论