• Arch Linux-获取或编译缺少的PHP扩展

    我已经安装了我的第一个Arch Linux安装程序,并且到目前为止为止都非常喜欢它,除了正确设置我的开发环境之外,还有一个小例外。 My previous OS was Ubuntu 16.04 on which I ran Nginx, PHP5.6-FPM and PHP7.0-FPM for my local Magento and Drupal development. Adding the ppa:ondrej/php repo, I was able to install all the add...
  • 无法在Debian Jessie上为PHP7.0安装xmlwriter,gd和bcmath

    I digging on stack exchainge whole morning and can't find right solution. I find a bunch of non existing repository and can't install xmlwriter, gd and bcmath for PHP 7.0. 我有基于Apache2,PHP7.0,MySql,phpMyAdmin的Linux服务器,想在服务器上添加ZABBIX,他需要这3个PHP扩展。 I change ph...
  • 如何在Centos 7上将PHP从5.4.16升级到> = PHP 5.6.5 / PHP 7?

    我正在使用centos 7,它附带了php 5.4.16。现在,我必须安装moodle moodle 3.2,至少需要PHP 5.6.5。 我尝试从remi和IUS储存库安装php,但是没有运气。我得到的只是错误:与以前的安装冲突。 如果我安装了任何其他版本的php,phpmyadmin将无法正常工作。 (我尝试在开发服务器上无法正常工作) 顺便说一下,我尝试了很多谷歌搜索..但最终没有解决方案。所以我必须创建这个。 如何在我的服务器上同时实现moodle和phpmyadmin? 非常感谢您的帮助。 请在下...
  • 升级到Stretch后,仙人掌停止工作

    刚刚将仙人掌服务器升级到Stretch / Debian9。升级完成后,仙人掌仍在工作。 清理剩下的Debian 8 PHP 5软件包后,仅安装了PHP 7.0,仙人掌停止工作,访问URL时仅显示空白页面。 Calling /usr/share/cacti/site/index.php from the command line gives the error: PHP Fatal error: Uncaught Error: Call to undefined function mysql_pconne...
  • 无法使用MYSQL工作台连接到Laravel Homestead数据库

    我无法通过mysql工作台连接到laravel homestead 这是我的联系方式 Homestead Connection http://simple.harry.zone/linux/homestead_connect.png 但我面临以下问题 Homestead Issue http://simple.harry.zone/linux/homestead_issue.png 编辑: 以下是Gerath在以下评论中要求的详细信息 1:服务器正在localhost(仅127.0.0.1)中运行 2.)宅...
  • httpd(apache2)服务器不解析* .php文件,但将其显示为带有已安装php-module的文本

    我正在尝试在archlinux上设置我的httpd(apache2)服务器。现在一切正常,除了解析我的php文件。 I followed this article: https://wiki.archlinux.org/index.php/Apache_HTTP_Server#PHP. 我已经 安装了php和php-apache软件包 配置的Apache使用prefork模块而不是事件模块 启用了php_7-module 包含了extra / php7_module.conf 像在我的Ubuntu上一样设...
  • 期待PECL for PHP 7

    I just upgraded to PHP 7.0.3, but there is no support for expect. Does anyone know if is it possible to bypass the installation issue? It says: root@portal:/home# pecl install expect-0.3.3.tgz pecl/expect requires PHP (version >= 4.0.0, version <= 5.99.99...
  • 已安装LAMP并希望从php7.2升级到php7.2-fpm的Ubuntu 18.04

    我有一个裸机Ubuntu 18.04盒子,我在Lamp上安装了LAMP,并在vhosts中安装了Minecraft dynmap。一切正常,但是我的NextCloud速度慢得可笑,我读过的所有书都说我应该使用php-fpm而不是普通的php。 我已经搜索并搜索了如何将php 7.2升级到fpm版本,我空手而归。我似乎找不到任何有关是否可以粘贴我的php.ini,如何告诉apache使用新版本而不是旧版本的信息,是否必须告诉每个虚拟主机独立使用它。一个Apache配置某处... 任何帮助表示赞赏。
  • PHP7.4的MySQL问题,尤其是Laravel6

    Doctrine \ DBAL \ Driver \ PDOException:SQLSTATE [HY000] [2006] MySQL服务器已消失 在〜/ PhpstormProjects / PropscoutFinal / vendor / doctrine / dbal / lib / Doctrine / DBAL / Driver / PDOConnection.php:31     27 | parent :: __ construct($ dsn,(string)$ user,(strin...
  • 尝试安装Curl时遇到问题

    我正在使用PHP 7.3.9运行Ubuntu 18.04服务器。 我正在尝试在服务器上安装Curl,主要是为了使站点可以与Mailchimp通信。 这样做会出现此错误: Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you ar...
  • 如何确定MediaWiki使用的PHP版本?

    在安装了MediaWiki 1.31.1的情况下运行Ubuntu 19.10。我有一个在Ubuntu 19.04下运行良好的Wiki,但是说 MediaWiki 1.31内部错误 需要安装一些PHP扩展。 所需组件 您缺少MediaWiki需要运行的PHP扩展名。请安装: xml (more information) 尽管xml是为PHP 7.3加载的。但是对于也已安装的7.2,则不会加载xml。我猜MediaWiki使用7.2。如何确定使用的版本?如果是错误的,它将如何改变?
  • PHP无法正常工作10.10

    Ubuntu 19.10,PHP无法正常工作。确实安装了Apache2,它可以工作。 任何想法?尝试了不同版本的PHP。当我尝试将数据应用于数据库或运行文件时,什么都没有出现。
  • 非常繁重的php fpm进程

    我在服务器上沉重的php-fpm有问题。以下是摘录: PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND 7631 <user> 20 0 583996 88932 72300 S 32.9 0.3 10:32.62 php-fpm7.2 我真的不明白这些过程如何能运行这么长时间。 由于我的内存限制为80M,而max_execution_time为60,有人可以告诉我这些进程如...
公告

欢迎访问 码农俱乐部  点击这里设置您的邮箱  可以接收站内跟帖、回复邮件提醒,不错过任何一条消息。

关注公众号订阅更多技术干货! 码农俱乐部