• 由于指针问题,旧项目无法在Delphi 4中编译

    我完全没有Delphi的经验,我有一个非常老的项目,可以在第2、3rd版的Delphi中进行编译,但在Delphi 4中却无法使用。问题在于指针在新版本中的工作方式有所不同。 这段代码导致错误“需要变量”: pEnabled := @pClrWire_s^.enabled; 其中pEnabled为: const pEnabled : ^boolean = nil; pClrWire_s也是一个指针: pClrWire_s : TpImage; {pointer to an image of...
公告

欢迎访问 码农俱乐部  点击这里设置您的邮箱  可以接收站内跟帖、回复邮件提醒,不错过任何一条消息。

关注公众号订阅更多技术干货! 码农俱乐部